Sign in to follow this  
Followers 0
SimonH

Cannot get a smooth clearcoat... Help!

4 posts in this topic

I use Envirotex Light to clearcoat my fishing lures and I do use a dying motor.

However I?m not able to achieve a perfect smooth finish on my lures, like most of you are, what I?m I doing wrong?

I?m not able to make some brush marks go away.

Also I read a lot of you are using Devcon 2 ton epoxy, does anybody know where to get it in Canada (Quebec)?

How about a good wood sealer for balsa wood that readily available in hardware stores (other than epoxy, since I?m using water base paint)?

Thank you all in advance for your answers!

Simon :huh:

Share this post


Link to post
Share on other sites

Simon, for Balsa you need the epoxy for your first coat for strength, not familar with envirotex lite but maybe your not brushing enough on ? Also needs to be above 65* whereever your drying rack is. I get my devcon at walmart.

Vmaxx

Share this post


Link to post
Share on other sites

I use Envirotex Lite, not Envirotex Light. Sorry for the typo and thank you for answer. I don't think the local Walmart here in Quebec have Devcon but I' ll have a look.

Simon

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0