jwest

New Paint Gun Problem

6 posts in this topic

jwest    0

I recently bought a paint gun at hobby lobby a Paasche. I have wasted 2 cans of air on this thing and i can't get any air to come out of the gun. I have air coming from the hose and the can, but when i hook it up to the gun and press the button nothing comes out.

I am using createx paint and i thinned it down, but i can't even get the paint to flow up the tube in the jar to paint.

What am i missing or doing wrong?

Share this post


Link to post
Share on other sites
BobP    834

What kind of airbrush is it? Give us a specific model number - different ones work differently.

If you pull the trigger but no air comes out of the gun - but you are still using up your air can - where is the air escaping to?

Share this post


Link to post
Share on other sites
LimpNoodle    76

As soon as you can buy a compressor. $50 should get you what you need if you shop carefully.

Those air cans are a waste of money.

Share this post


Link to post
Share on other sites
BobP    834

I see on "The Docks" that his airbrush is a single action Paasche, so most of the fixes for double action/internal mix a/b problems are not germane. You'd think single action airbrushes are about as simple as you can get. But adjusting the air flow on them can be pretty finicky. Ah yes, the Good Ole Days - running down to Michaels with a half-off coupon to buy a can of compressed air for my single action Badger. It actually worked OK and got me into lure painting for a total cost of $20, so no complaints. That was a long time ago and several airbrush upgrades ago.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now