Jump to content
mark poulson

site loading slowly

Recommended Posts

For the last couple of days this website has been loading slowly.  I tried both Google Chrome and Firefox, and it is the same.

Did you guys change something that I missed?

Edited by mark poulson

Share this post


Link to post
Share on other sites

Seems normal to me.

Standard response for problems is to delete all your history and stuff, always works when I have a problem. TU seems particularly sensitive to history problems.

Dave

  • Like 1

Share this post


Link to post
Share on other sites
On 2/29/2020 at 6:04 PM, alsworms said:

I'm kind of anal when it comes to my internet speeds.  I have Comcast, which is super fast, but you might try running a speed test.  I believe this one is universal.......

https://www.speakeasy.net/speedtest/

@alsworms Yes, that speed test is universal, and will work based on your location.

 

Another one I use is https://fast.com/

  • Like 2

Share this post


Link to post
Share on other sites
4 hours ago, Curt - RI said:

@alsworms You're not the only who is anal about speeds. I check mine daily, at my PC and at the router level :lol:

Twice a day here, brother!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...
Top